Jun 272008
 

quoted from http://liw.fi/programming-truths/

Originally written in 1995.
This page contains a number of important programming truths that every budding programmer should know about. These truths are self-evident, and need no explanations.

If it compiles, it works.
If it compiles, it’s correct.
If it runs, it doesn’t have any bugs.
If it doesn’t have any immediately obvious bugs, it’s perfect.
If a bug doesn’t show, it doesn’t exist.
If it seems to work, it works.
Doing something right is easy. Avoiding errors only takes a bit of concentration.
The shorter the source code, the faster the program.
It’s obvious how to optimize a program.
Prorammers don’t make mistakes.

Continue reading »

Jun 202008
 

“Mikrotīkls Ltd., known internationally as MikroTik, is a Latvian manufacturer of computer networking equipment. It sells wireless products and routers. The company was founded in 1995, with the intent to sell in the emerging wireless technology market. As of 2007, the company had more than 70 employees.”

Membagi bandwidth secara adil dengan mikrotik

Dengan menggunakan queue type pcq di Mikrotik, kita bisa membagi bandwidth yang ada secara merata untuk para user, saat jaringan pada posisi peak.

step2nya:

  1. Asumsi : Network Address 172.16.0.0/12, interface yang mengarah ke pengguna diberi nama Lan, dan interface yang mengarah ke upstream provider diberi nama Public;
  2. Ketikkan di console atau terminal :
          /ip firewall mangle add chain=forward src-address=172.16.0.0/12 \
             action=mark-connection new-connection-mark=users-con
          /ip firewall mangle add connection-mark=users-con action=mark-packet \
             new-packet-mark=users chain=forward
          /queue type add name=pcq-download kind=pcq pcq-classifier=dst-address
          /queue type add name=pcq-upload kind=pcq pcq-classifier=src-address
          /queue tree add name=Download parent=Lan max-limit=2048000
          /queue tree add parent=Download queue=pcq-download packet-mark=users
          /queue tree add name=Upload parent=Public max-limit=1024000
          /queue tree add parent=Upload queue=pcq-upload packet-mark=users
          /queue tree add parent=Lan queue=pcq-download packet-mark=users
          /queue tree add parent=Public queue=pcq-upload packet-mark=users
    
  3. selamat mencoba!!

note: LAN dan INTERNET adalah nama interface.LAN interface ke arah user/client,INTERNET interface ke arah ISP.