Aug 052010
 

source: http://www.linuxtopia.org/online_books/network_administration_guides/Linux+IPv6-HOWTO/hints-daemons-radvd.html

Router Advertisement Daemon (radvd)

The router advertisement daemon is very useful on a LAN, if clients should be auto-configured. The daemon itself should run on the Linux default IPv6 gateway router (it’s not required that this is also the default IPv4 gateway, so pay attention who on your LAN is sending router advertisements).

You can specify some information and flags which should be contained in the advertisement. Common used are:

  • Prefix (needed)
  • Lifetime of the prefix
  • Frequency of sending advertisements (optional)

After a proper configuration, the daemon sends advertisements through specified interfaces and clients are hopefully receive them and auto-magically configure addresses with received prefix and the default route.

Configuring radvd

Simple configuration

Radvd’s config file is normally /etc/radvd.conf. An simple example looks like following:

interface eth0 {
        AdvSendAdvert on;
        MinRtrAdvInterval 3;
        MaxRtrAdvInterval 10;
        prefix 2001:0db8:0100:f101::/64 {
                AdvOnLink on;
                AdvAutonomous on;
                AdvRouterAddr on;
        };
};

This results on client side in

# ip -6 addr show eth0
3: eth0: <BROADCAST,MULTICAST,UP> mtu 1500 qdisc pfifo_fast qlen 100
    inet6 2001:0db8:100:f101:2e0:12ff:fe34:1234/64 scope global dynamic
       valid_lft 2591992sec preferred_lft 604792sec
    inet6 fe80::2e0:12ff:fe34:1234/10 scope link

Because no lifetime was defined, a very high value was used.

Continue reading »

Jun 202008
 

“Mikrotīkls Ltd., known internationally as MikroTik, is a Latvian manufacturer of computer networking equipment. It sells wireless products and routers. The company was founded in 1995, with the intent to sell in the emerging wireless technology market. As of 2007, the company had more than 70 employees.”

Membagi bandwidth secara adil dengan mikrotik

Dengan menggunakan queue type pcq di Mikrotik, kita bisa membagi bandwidth yang ada secara merata untuk para user, saat jaringan pada posisi peak.

step2nya:

  1. Asumsi : Network Address 172.16.0.0/12, interface yang mengarah ke pengguna diberi nama Lan, dan interface yang mengarah ke upstream provider diberi nama Public;
  2. Ketikkan di console atau terminal :
          /ip firewall mangle add chain=forward src-address=172.16.0.0/12 \
             action=mark-connection new-connection-mark=users-con
          /ip firewall mangle add connection-mark=users-con action=mark-packet \
             new-packet-mark=users chain=forward
          /queue type add name=pcq-download kind=pcq pcq-classifier=dst-address
          /queue type add name=pcq-upload kind=pcq pcq-classifier=src-address
          /queue tree add name=Download parent=Lan max-limit=2048000
          /queue tree add parent=Download queue=pcq-download packet-mark=users
          /queue tree add name=Upload parent=Public max-limit=1024000
          /queue tree add parent=Upload queue=pcq-upload packet-mark=users
          /queue tree add parent=Lan queue=pcq-download packet-mark=users
          /queue tree add parent=Public queue=pcq-upload packet-mark=users
    
  3. selamat mencoba!!

note: LAN dan INTERNET adalah nama interface.LAN interface ke arah user/client,INTERNET interface ke arah ISP.